Chapter 7: Pivot Tables and Specialized Access Forms

Learning Objectives

This chapter covers features that allow you to use the more specialized objects of Excel and Access 2013. At the completion of this chapter, you should have acquired the knowledge and skills to:

- Understand the relationship between pivot tables and data cubes
- Understand the process to design a pivot table in Excel 2013
- Import an Access query and create a pivot table in Excel 2013 and
- Use filters to customize pivot tables in Excel 2013
- View a pivot table as a pivot chart in Excel 2013
- Create a split form and understand when it is appropriate in Access 2013
- Create a multiple items form and understand when it is appropriate in Access 2013

Overview

In other lab chapters you learned how to create the objects of a database application system. You created tables, queries, forms, and reports. This chapter shows you how to build and customize a few specialized objects. Pivot tables and charts are no longer supported by Access 2013. Instead, Excel 2013 can be used to create pivot tables and charts. You will create a pivot table to demonstrate how Excel supports decision making with multidimensional data. Pivot tables provide a more flexible interface for multidimensional data than crosstab queries presented in Chapter 6. The second part of the chapter provides practice with creating two specialized kind of forms, split forms and multiple item forms. These form types are easy to create and have some important but specialized uses so you should become familiar with them.

7.1 Pivot Tables

Data warehouse processing requires a multidimensional data representation that is convenient for business analysts. Data cubes, a widely accepted representation of multidimensional data, support operations for business intelligence processing by analysts. In a data cube, cells contain numeric data called measures while rows and columns contain dimensions to organize the cells. Textbook Chapters 16 and 17 provide detailed conceptual material about data cubes and other aspects of data warehouses.

In Excel, pivot tables and pivot charts provide a convenient and flexible interface for manipulating data cubes. Pivot tables display data in rows and columns and allow convenient rearrangement of the row and column headings. Pivot charts display numerical data graphically to provide insights to business analysts. Pivot tables support dynamic manipulation of the row and column headings as compared to the static representation of crosstab queries presented in Chapter 6. Pivot tables were first available in Access 2000, but Excel 2000 was needed to use them. Since Access 2002 until Access 2010, Excel was not needed to use pivot tables. Pivot charts were new in Access 2002. However, pivot tables and charts were discontinued in Access 2013. Pivot tables and charts can be created using Excel 2013 instead.

This section provides practice with pivot tables and pivot charts. Because the terminology of pivot tables is somewhat different than the terminology of data cubes in textbook Chapter 16, the first section presents background on pivot tables and pivot charts. The second section provides practice with creating pivot tables and viewing a pivot table as a pivot chart. The third section extends the pivot table presented in the second section and discusses additional pivot table features.

7.1.1 Background about Pivot Tables

To explain the Excel terminology, Figure 1 presents a pivot table for parts used data along with annotations to depict the terminology. Table 1 provides explanations for the annotated parts of Figure 1 along with some additional terms.
Table 1: Excel Terminology for Pivot Tables

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filters Field (1)</td>
<td>Restricts data that appears in the pivot table. <em>City</em> is a filter field. The user can choose to display pivot table data for selected cities by choosing a value for the <em>City</em> filter field.</td>
</tr>
<tr>
<td>Rows Field (2)</td>
<td>A field appearing in the row area of a pivot table. <em>PartDesc</em> and <em>TimeRecvd</em> are row fields.</td>
</tr>
<tr>
<td>Columns Field (3)</td>
<td>A field appearing in the column area of a pivot table. <em>Make</em> and <em>Model</em> are column fields.</td>
</tr>
<tr>
<td>Values Field (4)</td>
<td>A field appearing in the cell area of a pivot table. The numeric values in the cells are the sum of the parts used for the combination of the row and the column values. For example, $50 is the sales for gear boxes repaired in BMWs.</td>
</tr>
<tr>
<td>Field drop-down arrow</td>
<td>The arrow at the right side of each field. The user can select values to display or hide by clicking the arrow.</td>
</tr>
<tr>
<td>Item</td>
<td>A data value within a field. Expanding a field displays its items, while collapsing a field hides its items. In Figure 1, <em>PartDesc</em> and <em>Make</em> are expanded, while <em>TimeRecvd</em> and <em>Model</em> are collapsed.</td>
</tr>
</tbody>
</table>
Beyond understanding the Excel terminology, you should understand the correspondence between data cubes as presented in textbook Chapter 16 and pivot tables. Table 2 summarizes the correspondence between the terminologies. If you are unfamiliar with the data cube terminology, you should review textbook Section 16.2.

Table 2: Terminology Correspondence between Data Cubes and Excel Pivot Tables

<table>
<thead>
<tr>
<th>Data Cube Term</th>
<th>Excel Pivot Table Term</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>Row field, Column field</td>
</tr>
<tr>
<td>Measure, Measure value</td>
<td>Value field, Value item</td>
</tr>
<tr>
<td>Dimension hierarchy</td>
<td>Custom groups of a row field or column field. Date/Time fields have predefined groups. Dimension hierarchies can also be implemented using adjacent row or column fields.</td>
</tr>
<tr>
<td>Member</td>
<td>Row item, Column item</td>
</tr>
</tbody>
</table>

Before creating a pivot table, you should carefully plan its components and formulate a query (in Access) to retrieve the data contained in the pivot table (in Excel). In date cube terminology, you should determine the dimensions, dimension hierarchies, and measures. For each measure, you should determine whether it is a basic or a derived measure. For each derived measure, you should determine whether it is a summary value (computed from groups of rows) or a row value (computed from individual rows). Pivot tables containing row data are more flexible than pivot tables with only summary data although row data consumes more space than summary data. After determining the components of a pivot table, you should formulate the query to derive the data used in the pivot table. The query should contain all fields of the pivot table although derived measures can be calculated by either the pivot table or by the query. Beyond these general guidelines, here are some specific points to consider when designing pivot tables:

- With pivot tables, an important way to represent dimension hierarchies is using adjacent row or column fields. Typically, geographic dimension hierarchies such as country/region/state/city can be represented as adjacent fields.
- If the pivot table only contains summary measures, the underlying query can contain a GROUP BY clause and aggregate functions to compute the summary measures. However, defining the underlying query to retrieve row data instead of summary data provides more flexibility for modifications to the pivot table.
- If the pivot table contains at least one row measure, the underlying query should not have a GROUP BY clause. In addition, summary measures are computed by the pivot table, not by the query.

7.1.2 Creating Pivot Tables

Before discussing the steps to create pivot tables, the design of the pivot table example is presented. The pivot table should contain part descriptions and the makes and models of vehicles as dimensions. For measures, the amount paid for the repair along with the sum of the amount paid are the measures. For comparison purposes with the crosstab query in Chapter 6, we use RptQuery4 (shown in Figures 2 and 3) as the underlying query for the pivot table. The next section extends this simple pivot table design with additional fields and other pivot table features.
The following steps demonstrate how to create a pivot table in Excel 2013. After creating the pivot table, you will be instructed to modify it and manipulate its data.

1. **Import Access Query to Excel:** Make sure that the Access database is not running before you start. Open a new Excel file. Choose **DATA → Get External Data → From Access** (Figure 4). Navigate to where the database is located, select the database and click **Open**. A dialogue will appear showing the list of all tables, queries, reports and forms in the selected database. Select RptQuery4 and click **Ok** (Figure 5). Then, another dialogue will appear asking about how to view the imported query. Select PivotTable Report and put it in a new worksheet (Figure 6). If the database is open, the data link properties window will appear as in Figure 7. When you click on the test connection, an error message will appear as in Figure 8. Close the database and try again.

2. **View Field List:** A new sheet opens with a Field List window containing the fields necessary for laying out your pivot table (Figure 9).

3. **Place Fields on the Diagram:** To place the fields onto the diagram, you may drag them from the Field List window at the top into the designated areas at the bottom (Figure 10). Until you are familiar with the design window’s labeled areas, it is suggested that you use the area choices as follows: place the **PartDesc** field in the

---

**Figure 2: Design View of RptQuery4**

**Figure 3: Datasheet of RptQuery4**
rows area (Figure 11), the Make and Model fields in the columns area (Figure 12), and the Amount field in the values area (Figure 13).

![Figure 4: Import from Access Database](image)

![Figure 5: Table Selection Dialogue](image)
Figure 6: Import Data Dialogue

Figure 7: Data Link Properties
Chapter 7: Pivot Tables and Specialized Access Forms

Figure 8: Data Link Error

Test connection failed because of an error in initializing provider. You attempted to open a database that is already opened by user 'Admin' on machine 'SB3501-D'. Try again when the database is available.

Figure 9: Datasheet with PivotTable Fields
Figure 10: PivotTable Fields
Figure 11: PartDesc Field after Adding it in the Row Area
Figure 12: Make and Model Fields after Adding them in the Column Area
4. **Format Sum of Amount field**: To change the properties for the Sum of Amount field, click on the field title (“Sum of Amount”) in the values area. Then, choose the **Value Field Settings** option (Figure 14). A new window opens as in Figure 15. In the **Custom Name** area, change the name to “Parts Used Sales” (Figure 16). In the **Number Format**, change the Numbers to “Currency” (Figure 17) if there is another format specified. Click Ok when finished. In the diagram, the *Sum of Amount* field has changed to *Parts Used Sales* (Figure 18).
Figure 14: Value Field Settings Option
Figure 15: Value Field Settings Window

Figure 16: Changed Title Field Name
Figure 17: Changed Number Format

Currency formats are used for general monetary values. Use Accounting formats to align decimal points in a column.
5. **Modify the Pivot Table Sheet**: To modify the pivot table properties, right click anywhere in the pivot table and select **PivotTable Options** from the menu. Change the name to “Parts Used Pivot Table”. To rename the sheet, right click on (“Sheet2”) and select **Rename** from the option list. Rename the sheet to “Parts Used Pivot Table” and click Enter (Figure 19). Also, right click on (“Sheet1”) and select Delete. Save the Excel file as “PartsUsedPivotTable”.

6. **View the Pivot Table as a Pivot Chart**: To view the pivot table as a pivot chart, you need to choose **Insert → PivotChart** from the Charts section in the Ribbon (Figure 20). A new window opens with chart options (Figure 21). Select **Column** and click Ok. The pivot chart will show up as in Figure 22. Save the changes when you are finished. For more details about pivot charts, you are encouraged to study the Excel help documentation.
### Chapter 7: Pivot Tables and Specialized Access Forms

#### Figure 19: Pivot Table Sheet

<table>
<thead>
<tr>
<th>Parts Used Sales</th>
<th>Column Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMW Total</td>
<td>Buick Total</td>
</tr>
<tr>
<td>Row Labels</td>
<td>320i</td>
</tr>
<tr>
<td>10W-30 oil</td>
<td>$5.70</td>
</tr>
<tr>
<td>10W-40 oil</td>
<td>$3.95</td>
</tr>
<tr>
<td>AntiFreeze</td>
<td>$50.00</td>
</tr>
<tr>
<td>Battery</td>
<td></td>
</tr>
<tr>
<td>Brake Lining</td>
<td></td>
</tr>
<tr>
<td>GearBox</td>
<td></td>
</tr>
</tbody>
</table>

#### Figure 20: PivotChart Option
Figure 21: Pivot Chart Insert Window
7.1.3 Extending the Pivot Table

The pivot table in the previous section is somewhat limited because it lacks a time dimension, an important element of most data cubes. In addition, the pivot table lacks a filter field to restrict the data displayed. In this section, we add these elements to the previous pivot table and then demonstrate some additional features of pivot tables.

To extend the pivot table of the previous section, we first extend the underlying query and then create another pivot table with the additional fields. Follow these steps to create the new query and the pivot table.

1. **Modify the Underlying Query in Access**: Add the **Customer** table to the Query Design window as shown in Figure 23. Then, add the **RepairOrder.TimeRecvd** field and the **Customer.City** field to the query result. Save the query as “RptQuery4Revised” when you finish with the changes. Close the Access database.

2. **Define a New Pivot Table**: Using the same Excel sheet, follow step 1 from Section 7.2.1 to import a query from Access to Excel with **RptQuery4Revised** as the underlying query.

3. **Create Pivot Table Fields**: Drag **PartDesc** and then **TimeRecvd** from the field list to the row area of the pivot table. Then, drag **Make** and **Model** from the field list to the column area. Finally, drag **City** to the filter area. Figure 24 shows the resulting pivot table.

4. **Create the Detail Fields**: Drag **Amount** from the field list to the values area. Figure 25 shows the resulting pivot table.

5. **Rename the Calculated Field**: Change the name of the calculated field from “Sum of amount” to “Parts Used Sales” by using the **Custom Name field** of the Value Field Settings option. In the **Number Format**, change the Number to “Currency”. Figure 26 shows the resulting pivot table.

6. **Compact the Pivot Table**: Remove the members of the **TimeRecvd** and **Make** fields using the **Collapse** menu item. To remove the **TimeRecvd** items, right-click in any **PartDesc** field heading and select **Expand/Collapse**.
→ **Collapse Entire Field** from the menu (Figure 27). Similarly, to remove the Model items, right-click in any Make field heading and select **Expand/Collapse → Collapse Entire Field** from the menu. Figure 28 shows the compressed pivot table after collapsing both fields.

7. **Filter the Pivot Table**: To see the effect of filtering, use the drop-down arrow of the City field. Select “Seattle” from the drop down list. Figure 29 shows the pivot table after filtering for Seattle customers.

8. **Save the Pivot Table**: Change the name of the pivot table to “Part Used Pivot Table 2” using PivotTable Options. Then rename the pivot table sheet as “Part Used Pivot Table 2”. Close the excel file when you are finished.

![Figure 23: Revised Query for the Modified Pivot Table](image)

![Figure 24: Pivot Table after Dragging Fields to the Rows, Columns and Filters Areas](image)
### Figure 25: Pivot Table after Dragging Amount to the Values Area

<table>
<thead>
<tr>
<th>City</th>
<th>(All)</th>
<th>Amount</th>
<th>BMW Total</th>
<th>Buick Regal</th>
<th>Buick Total</th>
<th>Chevrolet Blazer</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>10/5/2013 16:20</td>
<td>10/7/2013 9:00</td>
<td>10/12/2013 14:30</td>
<td>10/18/2013 12:04</td>
<td></td>
</tr>
</tbody>
</table>

### Figure 26: Pivot Table after Changing the Name and Number Format

<table>
<thead>
<tr>
<th>City</th>
<th>(All)</th>
<th>Parts Used Sales</th>
<th>BMW Total</th>
<th>Buick Regal</th>
<th>Buick Total</th>
<th>Chevrolet Blazer</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Parts Used Pivot</td>
<td>10/5/2013 16:20</td>
<td>10/7/2013 9:00</td>
<td>10/12/2013 14:30</td>
<td>10/18/2013 12:04</td>
</tr>
</tbody>
</table>
Figure 27: Collapse Option
Figure 28: Pivot Table after Collapsing Fields
Excel also provides the ability to group row and column fields. For date/time fields, Excel provides predefined grouping levels using the **Group** option. For the **TimeRecvd** field, you can group on predefined intervals such as year, quarter, and month. Grouping to a finer or coarser level is comparable to drilling down or rolling up as described in textbook Chapter 16. You can determine groups for fields without predefined groups by selecting items and using the **Group** menu item.

![Figure 29: Pivot Table after Filtering on Seattle](image-url)
Chapter 7: Pivot Tables and Specialized Access Forms

7.2 Specialized Access Forms

This section covers two specialized Access forms, the split form and the multiple items form. These forms are easy to create and useful in specialized situations so you should become familiar with them.

7.2.1 Split Form

A split form, a new feature in Microsoft Office Access 2007, provides two views of data at the same time. You can view all records in a table in Datasheet view and the selected record in Form view. A split form ensures that both views are connected to the same data source and synchronized with each other. For example, if you select a field in one part of a split form, the same field is selected in the other part of the form. Split forms allow you to add, edit, or delete data from either part subject to the normal form constraints (allow properties and record source updatability).

A split form seems ideal for a situation in which a small group of rows should be reviewed at the same time. For example, a split form may be useful to review interesting subsets of vehicles such as vehicles of the same model, make, and year.

This section provides practice with creating a split form and modifying an existing form into a split form. Both tasks can be accomplished easily as demonstrated by the instructions in this section.

New Split Form

1. Select Table: In the Navigation pane, select the Tables menu. Then select the Vehicle table.
2. Create the Split Form: While the Vehicle table is selected in the Navigation pane, select Create → More Forms → Split Form in the Forms group of the Ribbon. The split form appears in the view pane in Layout view (Figure 30).
3. Navigate Records: Navigate records in Datasheet view and see the current record change in Layout view. Access ensures that the actions on each form are synchronized. Figure 31 shows the second record in Layout view with the second record selected in Datasheet view.
4. Navigate Fields: Select different fields to see that the same field is selected in the other view. In Figure 33, the Model field is selected in both views. In Form view, the field in the single form area is not highlighted as shown in Figure 33. Note, however, that the records in the single form and datasheet parts are still synchronized.
5. Save the Form: Close the form and save it as “Vehicle-SplitForm”.

...
Figure 30: Split Form in Layout View for the Vehicle Table
Figure 31: Split Form in Layout View Showing the Second Record Selected in Both Views
Figure 32: Split Form in Layout View Showing the Model Field Selected in Both Views
Modify an Existing Form to a Split Form

1. **Create New Form**: In the Navigation pane, select the **Tables** item. Then select the **Customer** table.

2. **Create a Form**: While the **Customer** table is selected in the Navigation pane, select **Create → Form** in the Forms group of the Ribbon. The form appears in the view area in Layout view (Figure 34).

3. **Open Property Sheet**: Open the new Customer form in Design view. Open its Property Sheet by clicking **Design → Property Sheet**. Alternatively, you can type **F4** to see the property sheet after selecting the form.

4. **Select Form**: In the Property Sheet, select Form in the Selection Type combo box as shown in Figure 35.

5. **Change the Default View Property**: On the **Format** tab of the property sheet, select “Split Form” in the **Default View** property as shown in Figure 36.

6. **View the Form**: Switch to Form View to see the split form view of the new Customer form (Figure 37).

7. **Save the Form**: Close the form and save it as “Customer-SplitForm”.

---

Figure 33: Split Form in Form View with the Model Field Selected in Datasheet View
Figure 34: Layout View for the Customer Form
Figure 35: Property Sheet Showing the Form Properties
Figure 36: Property Sheet Showing “Split Form” Chosen for the Default View Property
7.2.2 Multiple Items Form

A multiple items form\(^1\) displays data from more than one record at the same time. When first created, a multiple items form resembles a datasheet. A multiple items form is appropriate for power users who want a stylized datasheet for data entry. The process of creating a multiple items form is similar to creating a split form as presented in the remainder of this section.

1. **Select Table**: In the Navigation pane, select the **Tables** item. Then select the **Vehicle** table.

2. **Create the Split Form**: While the **Vehicle** table is selected in the Navigation pane, select **Create → More Forms → Multiple Items** in the Forms group of the Ribbon. The multiple items form appears in the View pane in Layout view (Figure 38).

3. **Change to Form View**: Click **Home → View → Form View** to see the same form in Form view (Figure 39). Form view appears similar to Layout view except for the highlighted fields in Layout view.

4. **Change to Design View**: Click **Home → View → Design View** to see the same form in Design view (Figure 40). The heading area shows the labels for the datasheet headings and the detail area shows the textboxes for the datasheet rows.

5. **Review Property Sheet**: In Design view, click **Design → Property Sheet** to open the Property Sheet for the multiple items form. Note that the **Default View** property is set to “Continuous Forms” as shown in Figure 41.

6. **Save the Form**: Close the form and save it as “Vehicle-MultipleItemsForm”.

---

\(^1\) A multiple items form is sometimes called a continuous form.
Figure 38: Multiple Items Form in Layout View for the Vehicle Table

Figure 39: Multiple Items Form in Form View for the Vehicle Table
Figure 40: Multiple Items Form in Design View for the Vehicle Table

Figure 41: Property Sheet for the Vehicle Multiple Items Form
Closing Thoughts

This chapter has covered specialized database objects, pivot tables, split forms, and multiple item forms. Pivot tables provide a convenient interface for manipulating multidimensional data, a common format for business analysis. You learned about the vocabulary for pivot tables and steps in designing a pivot table. Since Access 2013 does not support pivot tables, you gained practice to import queries from Access 2013 into Excel 2013 and create and customize pivot tables in Excel 2013. The practical material presented in Section 7.1 complements the conceptual material in textbook Chapter 16. Split forms and multiple item forms have important but specialized uses. They are simple to create and modify when needed.

This chapter concludes the study of individual database objects for application development. Chapter 8 integrates the material from other chapters in the coverage of navigation aids and customization of database objects using macros.

Chapter Reference

The chapter reference section summarizes procedures that you practiced. For wizards discussed in the chapter, the procedures highlight important parts of the wizards but do not list all of the steps.

Procedure 1: Creating a Pivot Table (Section 7.1.2)

1. Before creating a pivot table, you should determine the dimensions and measures of the data cube that it supports.
2. The underlying query for the pivot table should include all fields in the pivot table except for fields that are computed in the pivot table.
3. Use “Get External Data” utility to import queries from Access database.
4. Use the PivotTable option to choose the row fields, column fields, filter fields, and value fields from the fields in the underlying query.
5. Use Value Field Settings to change the properties of individual fields in the pivot table.
6. Use pivot table options to change the pivot table properties such as the name property.

Procedure 2: Create a Split Form (Sections 7.2.1)

1. Choose the object (table or updatable query) in the Navigation pane for which you want to create the split form.
2. Click Create → More Forms → Split Form in the Forms group of the Ribbon to create a split form for the object selected in the Navigation pane.
3. The form opens in Layout view. In Layout view, selecting a field highlights it in Datasheet view.
4. You can switch views (Design, Layout, and Form) using the Home → View drop down list.
Procedure 3: Modify a Form to a Split Form (Sections 7.2.1)

1. Choose the form in the Navigation pane for which you want to modify into a split form.
2. While the form is selected in the Navigation pane, open the form in Design view by right clicking on the form and selecting **Design View**.
3. After the form opens in Design view, open its Property Sheet by clicking **Design → Property Sheet**.
4. In the **Format** tab of the property sheet, select “Split Form” in the **Default View** property.

Procedure 4: Create a Multiple Items Form (Section 7.2.2)

1. Choose the object (table or updatable query) in the Navigation pane for which you want to create the split form.
2. Click **Create → More Forms → Multiple Items** in the Forms group of the Ribbon to create a multiple items form for the object selected in the Navigation pane.
3. The form opens in Layout view.
4. You can switch views (Design, Layout, and Form) using the **Home → View** drop down list.

**Additional Practice**

The following problems provide additional practice with the extended auto repair database as well as the textbook databases.

**Pivot Tables for the Extended Auto Repair Database**

1. Create a pivot table to support decision making about the labor costs of repairs. Your pivot table should support a data cube with dimensions of make, model, labor code, and starting repair date and measures for the actual labor cost, the standard labor cost, and the labor cost difference (actual labor cost minus standard labor cost). You need to write the underlying query in Access 2013 and then create the pivot table using Excel 2013.

2. Create a pivot table to support decision making about part expense for vehicles. Your pivot table should support a data cube with dimensions of make, model, cylinders, starting repair date and measures for the total part expense and the number of repairs. You need to write the underlying query in Access 2013 and then create the pivot table in Excel 2013. The pivot table should also have vehicle state as a filtering field.